Some Z-Moves are not corrected

Report problems here
Post Reply
Toefistju
Posts: 2
Joined: Wed Apr 16, 2014 12:22 am

Some Z-Moves are not corrected

Post by Toefistju » Wed Apr 16, 2014 12:35 am

Was engraving a slightly bowed piece of metal, used Autoleveller to contour the engraving to match.

Engraving was going very well, except for the final pass of the lettering. Towards the higher portions of the piece, the bit was driving much further that it should be on the corners of letters. Did a test without levelling in a small section to ensure the file was correct before using autoleveller and it was.

Looked at the gcode and found the issue, here's an example:

Original Lines:
N1550G1X0.2965Y1.0829Z-0.0050
N1560G1X0.3274
N1570G1X0.3303Y1.0800Z0.0000

Autoleveller output:
#102=[#504+0.49881*#506-0.49881*#504]
#101=[#505+0.49881*#507-0.49881*#505]
#100=[#102+0.68809*#101-0.68809*#102]
N1550G1X0.2965Y1.0829Z[#100 + -0.005]
#102=[#504+0.49881*#506-0.49881*#504]
#101=[#505+0.49881*#507-0.49881*#505]
#100=[#102+0.75981*#101-0.75981*#102]
N1560G1X0.3274 Z[#100 + -0.005]
N1570G1X0.3303Y1.08Z0

So I'm seeing that the first two lines are correct, but the third line has NO Z correction on it!

This is supposed to be a little "pull out" of a letter corner to form a nice sharp point, but the autoleveller code actually drives the bit deeper into every corner because the material is higher than 0 at this point, making for some very bad lettering.

If the material were lower there, it would still be a problem, as the bit would not properly create the corner. That last move to Z0 should be adjusted to meet the PROBED surface, not 0.

Not sure why autoleveller ignores these moves.

If this gets resolved, autoleveller can be use for general engraving purposes. Otherwise I'll need to find another solution. Thank you for looking into this!

Toefistju
Posts: 2
Joined: Wed Apr 16, 2014 12:22 am

Re: Some Z-Moves are not corrected

Post by Toefistju » Wed Apr 16, 2014 12:57 am

I did just discover one workaround in case anyone else is running into this problem. I set my "Start Depth" for the engraving toolpath at .0001" instead of 0". This is a small enough difference that I or my machine will barely notice, but autoleveller handles it properly now.

FYI I am using Vetric Aspire for most things, and coppercam for PCB stuff.

daedelus
Site Admin
Posts: 377
Joined: Tue Oct 01, 2013 1:41 pm
Location: London, UK
Contact:

Re: Some Z-Moves are not corrected

Post by daedelus » Fri Apr 18, 2014 10:05 am

The AutoLeveller will assume that anything below Z0 (any negative value) is a "cut". Any non-negative value is assumed to be above the material and not a "cut" and is why there is no correction on this 3rd line where Z is 0.

Your workaround presumably changes the previous Z0's into Z-0.001 and is why AutoLeveller now works correctly.

Nice one.
http://www.autoleveller.co.uk/. Software to probe and adjust a GCode file for PCB's or any probe-able surface.

http://www.autoleveller.co.uk/cnc-probe-guide/. A short guide to setting up the probe.

-James

NACK
Posts: 3
Joined: Wed Aug 27, 2014 10:21 pm

Re: Some Z-Moves are not corrected

Post by NACK » Wed Aug 27, 2014 10:30 pm

#102=[#502+0.468978*#518-0.468978*#502]
#101=[#503+0.468978*#519-0.468978*#503]
#100=[#102+0.461676*#101-0.461676*#102]
G1 X24.73 Y4.83 Z[#100 + -0.1]
#102=[#502+0.468978*#518-0.468978*#502]
#101=[#503+0.468978*#519-0.468978*#503]
#100=[#102+0.461676*#101-0.461676*#102]
G0 F1500 Z[#100 + -0.001]

this code has redundant calculate block:
#102=[#502+0.468978*#518-0.468978*#502]
#101=[#503+0.468978*#519-0.468978*#503]
#100=[#102+0.461676*#101-0.461676*#102]

because X and Y not changed.

And it would be good to make the correction of height on the movements of Z to zero.
This is quite reasonable and not difficult. Just change the condition if(Z<0) to if(Z< = 0).
Thanks.

Post Reply