Trouble with Autoleveler and Java

Help for setting up and using
Post Reply
lear
Posts: 2
Joined: Tue Jun 18, 2019 7:33 pm

Trouble with Autoleveler and Java

Post by lear » Tue Jun 18, 2019 8:31 pm

Hello!
I'm having issues running autolevellerAE on Debian Stretch 9.9. I currently have java 11 installed, but each time I try to run the launch command:

java -jar AutolevelerAE[version].jar

I get the following error:

Error: Could not find or load main class com.cncsoftwaretools.autoleveller.Autoleveller
Caused by: java.lang.NoClassDefFoundError: javafx/application/Application

And as a result Autoleveller doesn't launch.
I've also tried installing java 12, but that results in the same error.
Any help on the issue would be much appreciated.
Thanks!

daedelus
Site Admin
Posts: 375
Joined: Tue Oct 01, 2013 1:41 pm
Location: London, UK
Contact:

Re: Trouble with Autoleveler and Java

Post by daedelus » Mon Jul 01, 2019 5:08 pm

Try downgrading. Ive heard reports it doent work on Java 10 and above.

Im stuck in the dark ages and compile using Java 8 u121.
http://www.autoleveller.co.uk/. Software to probe and adjust a GCode file for PCB's or any probe-able surface.

http://www.autoleveller.co.uk/cnc-probe-guide/. A short guide to setting up the probe.

-James

lear
Posts: 2
Joined: Tue Jun 18, 2019 7:33 pm

Re: Trouble with Autoleveler and Java

Post by lear » Tue Jul 09, 2019 3:35 am

Thanks so much, this fixed it!
Also, just to let you know, the tech admin tutorial pinned in the forum is no longer supported by the repositories they reference. It looks like the only way to install java 8 anymore is to find a bootleg .tar file
Thanks again!

Post Reply