Probing stops at random

Help for setting up and using
Post Reply
Bluebell
Posts: 1
Joined: Wed Feb 19, 2020 12:10 am

Probing stops at random

Post by Bluebell » Mon Jun 08, 2020 2:50 am

I hace use AutoLeveller with great success on PCBs up to 150 x 300mm.

I am now level probing a 300mm x 300mm PCB blank. GCode generated for 10mm intervals and runs ok - but.

Probing stops several times in the program with (Mach 3) RESET flashing. Reset starts the process again but the resulting output file has results missing for the lines at the points of stopping. AutoLeveller then rejects input of the results file as "Format incorrect or the number of points per row not the same for each row"

After research set Mach 3 debounce to a higher setting, but the program still stops.

So, in desperation, wrote an XL macro to find the missing lines. Then inserted the missing lines with z values interpolated between the adjacent line's Z values. Then I output the file as text. Result was an output file visually in the same format as the original result file, but now with the same number of points for all rows.

Autoleveller rejected this file. With detailed examination in Hex and other file comparison program I can see no difference in the original or repaired files (other than the inserted lines).

Does anyone have any suggestions:
1. Why the GCode stops probing and goers into RESET?

2. What other reasons might there be for AutoLeveller to reject the file?

3. What is the format Autoleveller expects, including any header and EOF detail?

4. Any other ideas????

Post Reply